
 
The IoT Platform for Science/Education 

The Scimodo IoT Platform for Science Education provides students and teachers with 
hands-on STEM education activities in the world of Making, Coding, and Cloud Computing.  We 
develop creative and inspiring microcontroller projects that are designed to connect with 
Scimodo's Cloud Data Monitoring and Collaboration Portal. Scimodo provides an environment in 
which students can build, learn, share, and collaborate in the wonderful world of software and 
hardware development, electronics, and mechanical engineering. 

 
Our First Project | The Environmental Sensor Project teaches students how to build and 
program a microcontroller based environmental sensing device and use it to monitor the effects 
of light, humidity, temperature, sound, and soil moisture to gain insights on how these 
environmental conditions impact plant growth. The sensor data from your project is stored in the 
Scimodo Cloud where it can be accessed and monitored through a set of customizable graphs 
and gauges. You can access and download the Environmental Influence on Plant Growth 
Lesson Plan at www.scimodo.com/lessons 
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Step 1: Review the Included Parts 
1. Development Breadboard 
2. Jumper wires 
3. Arduino MKR1000 Microcontroller 
4. Combination Humidity/Temperature Sensor 
5. Soil Hydration Sensor Kit 
6. Ambient Sound Sensor 
7. Ambient Light Sensor 

 

    

Fig 1: Breadboard Fig 2: Jumper Wires Fig 3: MKR1000 Fig 4: Temperature 
Humidity Sensor 

    

Fig 5: Soil Hydration 
Sensor 

Fig 6: Sound Sensor Fig 7: Ambient Light 
Sensor 

 

  

 

 
2 Scimodo © 

 



 
 

 

Step 2: Assemble the Soil Hydration Sensor Kit 
For this step, you will need the Soil Hydration Sensor Kit and two jumper wires shown in Figure 
2 & 5. The color of the jumper wires do not matter, but we will be referencing specific colors 
tutorial to make it easier to follow the directions. Additionally, it does not matter if the wires are 
connected or pulled apart. 
 
To assemble the Soil Hydration Sensor, connect one end of the blue and teal wire to the two 
pins on YL-69 Module as shown in Figure 8.  
 

 

Fig 8: Adding Jumper Wire to YL-69 Soil Hydration Sensor 

Then connect the other ends of the blue and teal wires to the YT-38 Module. The YT-38 Module 
has 4 pins on one side, and 2 pins on the other. Connect the wires to the side of YT-38 that has 
2 pins as shown in Figure 9. The completed Soil Hydration Sensor is shown in Figure 10. Set 
the sensor aside for use later. 
 

 

Fig 9: Adding Jumper Wire to the YT-38 Soil 
Hydration Sensor 

Fig 10: Completed Soil Hydration Sensor 

 

 
3 Scimodo © 

 



 
 

 

Step 3: Attach the MKR1000 to the Breadboard 
For this step, you will need the Arduino MKR1000 (Figure 3) and the Development Breadboard 
(Figure 1).  The MKR1000 has 2 rows of pins protruding from the bottom of it. Line the pins up 
with columns “b” and “h” and rows 1-14 on the breadboard as seen in Figure 11.  
 

  

Fig 11: Lining up the MKR1000 on the Breadboard 

 
Carefully press down on the top of the MKR1000 to press the pins into the Breadboard. Make 
sure to place the Breadboard on a hard surface when pressing the MKR1000 into it or 
you may damage the Breadboard. The finished product is seen in Figure 12. Note: The 
MKR1000 may not sit flush with the Breadboard, and that is OK. 
 

 
Push down gently but firmly 

 
A small gap is OK 

Fig 12: MKR1000 Attached to the Breadboard 
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Step 4: Add the Sensors to the Breadboard 
For this step, you will need the Breadboard, the Humidity/Temperature Sensor (Figure 4), the 
Hydration Sensor, the Sound Sensor (Figure 6), and the Ambient Light Sensor.  
 
Attach the Humidity/Temperature Sensor to the Breadboard by attaching the pins on column “d” 
rows 19-21, and the Sound Sensor on column “d” rows 27-30 as seen in Figure 13.  
 

 

Fig 13: Attaching the Temperature/Humidity and Sound Sensor to the Breadboard 
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Attach the Hydration Sensor to the Breadboard on column “h” rows 27-30 as seen in Figure 14. 
Also attach the Ambient Light Sensor to the Breadboard on column “h” rows 19-22 as seen in 
Figure 14. 
 

Fig 14: Attaching the Soil Hydration and Ambient Light Sensor to the Breadboard 

 
Notice how the circuitry on the sensors is facing outwards in Figure 13 and 14. This is not 
necessary, but should be followed to ensure that the wiring in steps 4 and 5 is completed 
correctly. 
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Step 5: Connect Power and Ground Wires 
For this step, you will need the Breadboard, and 6 red and 6 black jumper wires. Attach one red 
wire to the header on the MKR1000 labeled 5V, and one black wire to the header on the 
MKR1000 labeled GND (Ground) as shown in Figure 15. 
 
The other end of the red wire goes on the positive rail of the Breadboard, and the other end of 
the black wire goes on the negative rail of the Breadboard as shown in Figure 16. They are 
called rails because all of the pins labeled positive on the breadboard are electrically connected, 
and all the pins labeled negative on the breadboard are electrically connected.  
 

  

Fig 15: Ground and Power on the MKR1000 Fig 16: Ground and Power on the positive 
and negative rails 

Note: The positive and negative rail on the left side of the board is isolated from the positive and 
negative rail on the right side of the board. To connect the rails on the left and right side of the 
Breadboard, attach the two sides by connecting the positive and negative rails with red and 
black jumper wires as shown in Figure 17 and 18. 

  

Fig 17: Red goes to positive and black to 
negative 

Fig 18: Note how the polarity of the rails 
switches on the other side 
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Next, add the power and ground wires to the Hydration Sensor. Notice how the pins are labeled 
VCC, GND, DO, and AO (Figure 19)? GND stands for Ground, and is your negative connection, 
and VCC stands for Voltage, and is your positive connector. We will explain the DO and AO 
pins in step 5. Attach one black wire to pin 29j on the Breadboard and the negative rail as 
shown in Figure 20. Pin 29j is attached to the GND pin on the Hydration Sensor. 
 
 

  

Fig 19: Pinout on the Hydration Sensor 
 

Fig 20: Adding the Ground wire to the 
Hydration Sensor 
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Attach one red wire to pin 30j on the Breadboard and the positive rail as shown in Figure 21. Pin 
30j is attached to the VCC pin on the Hydration Sensor. 
 

 

Fig 21: Adding the Positive wire to the Hydration Sensor 

The Ambient Light sensor has 3 pins: AO, GND, and VCC. The AO pin will be used in step 5. 
Attach one black wire to pin 21j on the Breadboard and the negative rail as shown in Figure 22. 
Pin 21j is attached to the GND pin on the Ambient Light sensor. Attach one red wire to pin 22j 
on the Breadboard and the positive rail as shown in Figure 23. Pin 22j is attached to the VCC 
pin on the Ambient Light sensor. 
 

  

Fig 22: Adding Ground wire to the Ambient 
Light Sensor 

Fig 23: Adding the Positive wire to the 
Ambient Light Sensor 
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The Temperature/Humidity sensor has 3 pins: GND, Data, and VCC. The Data pin will be used 
in step 5. Attach one black wire to pin 19a on the Breadboard and the negative rail as shown in 
Figure 24. Pin 19a is attached to the GND pin on the Temperature/Humidity sensor. Attach one 
red wire to pin 21a on the Breadboard and the positive rail as shown in Figure 25. Pin 21a is 
attached to the VCC pin on the Temperature/Humidity sensor. 
 

  

Fig 24: Adding Ground wire to the 
Temperature/Humidity Sensor 

Fig 25: Adding the Positive wire to the 
Temperature/Humidity Sensor 
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The Sound sensor has 4 pins labeled AO, GND, +, and DO. The + pin is for the positive voltage, 
and serves the same purpose as the VCC pins in the previous sensors. The AO and DO pins 
will be used in step 5. Attach one black wire to pin 28a on the Breadboard and the negative rail 
as shown in Figure 26. Pin 28a is attached to the GND pin on the Sound sensor. Attach one red 
wire to pin 29a on the Breadboard and the positive rail as shown in figure 27. Pin 29a is 
attached to the + pin on the Sound sensor. 
 

  

Fig 26: Adding the Ground wire to Sound 
Sensor 

Fig 27: Adding the Positive wire to the Sound 
Sensor 
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Step 6: Connect Data Wires 
For this step, you will need the Breadboard and the yellow, green, blue, and purple jumper 
wires. Attach one end of the yellow, green, blue, and purple jumper wires to the A3, A4, A5, and 
A6 headers on the MKR1000 as shown in Figure 28. The colors used on the pins do not matter, 
but should be followed to make sure that the rest of this step is completed correctly. 
 

 

Fig 28: Adding the Data Jumper Wires to the MKR1000 

Connect the other end of the yellow wire to pin 19j as shown in Figure 29. This connects the 
header A3 on the MKR1000 with the AO (Or analog out) pin on the Ambient Light Sensor. 
Connect the other end of the green wire to pin 29j as shown in Figure 30. This connects the 
header A4 on the MKR1000 with the AO (Or analog out) pin on the Hydration Sensor. 
 

  

Fig 29: Connecting the Yellow Wire to the 
Ambient Light Sensor 

Fig 30: Connecting the Green Wire to the 
Hydration 
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Connect the other end of the blue wire to pin 27a as shown in Figure 31. This connects the 
header A5 on the MKR1000 with the AO pin on the Sound sensor. Connect the other end of the 
purple wire to pin 20a as shown in Figure 30. This connects the header A6 on the MKR1000 
with the Data pin on the Temperature/Humidity sensor. This completes the setup of the 
Hardware. See the front cover for a complete view of the Scimodo Kit. In Step 6, we will be 
setting up the software. 
 

 

Fig 31: Connecting the Green Wire to the Sound Sensor and Blue Wire to the 
Temperature/Humidity Sensor 
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Step 7: Setup the Arduino IDE 
Follow the steps on https://www.arduino.cc/en/Main/Software to download and install the 
Arduino IDE 
 
Once the Arduino IDE is installed, you will also need to install 3 Arduino libraries. Open the 
Arduino IDE, and once it has loaded, open the Sketch menu, and select Sketch -> Include 
Library -> Manage Libraries. 
 

 
 
In the Arduino Library Manager, search for ArudinoJSON, select Version 5.11.2, and click the 
Install button 

 
 
Next, search for WiFi101, select Version 0.10.0, and click the Install button 

 
You can now close the Library Manager.  
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https://www.arduino.cc/en/Main/Software


 
 

 

Step 8: Configure the Arduino IDE to use the MKR1000 Board 
Next, we will configure the Arduino IDE to use the drivers for the MKR1000 Board. To do this, 
go to the Tools -> Board -> Boards Manager menu 

 
Next, search for the MKR1000 board in the upper right of the Boards Manager window. Select 
the “Arduino SAMD Boards (32-bits ARM Cortex-M0+)” board and press the Install button. The 
install procedure can take several minutes. It will look like the below image until the new Board 
is done installing. 

 
Once the Board is installed, the word “Installed” will display next to the board name, and the 
Cancel button will be replaced with a Close button. You can close the Board Manager. 

 
Finally, select the MKR1000 board by going to the Tools -> Board menu, and selecting the 
“Arduino/Genuino MKR1000” board. 
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Step 9: Set up your Arduino Sketch (Program) 
Download the zip file located at https://portal.scimodo.com/scimodo.zip. Extract that zip file to 
your desktop. Open the Arduino IDE, and go to the File menu, and select Open.  
 
Navigate to the scimodo folder you just extracted, select the scimodo.ino file, and press Open. 
Note: Your computer might not be configured to show file extensions. If so, select the 
scimodo file and press Open. 
 

 
 
Go to the SM_Cloud.h file and set your device and project ID provided on 
https://portal.scimodo.com/#introduction. Your device and project ID will be different than the 
ones shown in this document. 
 

 
 
Finally, to connect to your school’s network, enter your SSID and password for the wifi network 
as provided by your teacher. 
 
Compile your Arduino sketch by pressing the checkmark shown below.  

 
Your sketch has successfully compiled when you see “Done compiling” in the status bar as 
shown in Figure 32. If you see an error similar to Figure 33 please see your teacher for help. 
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https://portal.scimodo.com/scimodo.zip
https://portal.scimodo.com/#introduction


 
 

 

  

Figure 32: Successful Compile Figure 33: Error while Compiling 

 
 
Connect your MKR1000 to your computer via the provided USB cable. Once your sketch has 
compiled, you can upload it by pressing the arrow shown below.  
 

 
 
This will upload your sketch to your MKR1000. Your MKR1000 will now attempt to connect to 
the Scimodo Cloud and begin recording sensor data. Go to 
https://portal.scimodo.com/#introduction and wait for the box at the bottom to say that your 
device has connected to the Scimodo Cloud. If the device does not connect within 5 minutes, 
please double check your Device ID, Project ID, and WiFi login credentials. 
 
You can now unplug your MKR1000 from your computer, and connect it to the provided power 
supply. 
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Step 10: Create your first Charts 
Once https://portal.scimodo.com/#introduction shows that your device has connected to the 
Scimodo Cloud, click the green button shown below, and the portal will guide you to create your 
first chart. You can add, remove, or modify the charts to fit your assignment. 
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